summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-12 21:16:54 +0200
committerPaolo Bonzini2020-08-21 12:30:11 +0200
commit5ee24e78f5af0e4be7c6c7192541ca5fd7b0cf96 (patch)
tree0cf5eaa258e764a02bfbae311e6ac0499d0705ec /meson.build
parentcontrib/vhost-user-gpu: convert to meson (diff)
downloadqemu-5ee24e78f5af0e4be7c6c7192541ca5fd7b0cf96.tar.gz
qemu-5ee24e78f5af0e4be7c6c7192541ca5fd7b0cf96.tar.xz
qemu-5ee24e78f5af0e4be7c6c7192541ca5fd7b0cf96.zip
contrib/ivshmem: convert to meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 71ef66e1d6..c1078b6759 100644
--- a/meson.build
+++ b/meson.build
@@ -94,6 +94,7 @@ libcap_ng = not_found
if 'CONFIG_LIBCAP_NG' in config_host
libcap_ng = declare_dependency(link_args: config_host['LIBCAP_NG_LIBS'].split())
endif
+rt = cc.find_library('rt', required: false)
libiscsi = not_found
if 'CONFIG_LIBISCSI' in config_host
libiscsi = declare_dependency(compile_args: config_host['LIBISCSI_CFLAGS'].split(),
@@ -283,6 +284,10 @@ if have_tools
subdir('contrib/vhost-user-input')
subdir('contrib/vhost-user-scsi')
endif
+ if 'CONFIG_IVSHMEM' in config_host
+ subdir('contrib/ivshmem-client')
+ subdir('contrib/ivshmem-server')
+ endif
endif
subdir('tools')