summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Bennée2021-05-27 18:03:15 +0200
committerAlex Bennée2021-06-07 15:42:47 +0200
commit63de93530fe7d56dc0ba8b95f1dc8ba43ec237f3 (patch)
treee3caeda8285c30f45b8ef3532d7f53f8e8d32777 /meson.build
parenttests/tcg: add a multiarch signals test to stress test signal delivery (diff)
downloadqemu-63de93530fe7d56dc0ba8b95f1dc8ba43ec237f3.tar.gz
qemu-63de93530fe7d56dc0ba8b95f1dc8ba43ec237f3.tar.xz
qemu-63de93530fe7d56dc0ba8b95f1dc8ba43ec237f3.zip
meson.build: fix cosmetics of compiler display
If you specify something like --cc="ccache gcc" on your configure line the summary output misses the rest of the cmd_array. Do some string joining to make it complete. Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Tested-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20210527160319.19834-3-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 626cf932c1..d2a9ce91f5 100644
--- a/meson.build
+++ b/meson.build
@@ -2537,15 +2537,15 @@ summary(summary_info, bool_yn: true, section: 'Configurable features')
summary_info = {}
summary_info += {'host CPU': cpu}
summary_info += {'host endianness': build_machine.endian()}
-summary_info += {'C compiler': meson.get_compiler('c').cmd_array()[0]}
-summary_info += {'Host C compiler': meson.get_compiler('c', native: true).cmd_array()[0]}
+summary_info += {'C compiler': ' '.join(meson.get_compiler('c').cmd_array())}
+summary_info += {'Host C compiler': ' '.join(meson.get_compiler('c', native: true).cmd_array())}
if link_language == 'cpp'
- summary_info += {'C++ compiler': meson.get_compiler('cpp').cmd_array()[0]}
+ summary_info += {'C++ compiler': ' '.join(meson.get_compiler('cpp').cmd_array())}
else
summary_info += {'C++ compiler': false}
endif
if targetos == 'darwin'
- summary_info += {'Objective-C compiler': meson.get_compiler('objc').cmd_array()[0]}
+ summary_info += {'Objective-C compiler': ' '.join(meson.get_compiler('objc').cmd_array())}
endif
if targetos == 'windows'
if 'WIN_SDK' in config_host