summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAkihiko Odaki2022-08-19 15:27:56 +0200
committerGerd Hoffmann2022-09-23 14:36:33 +0200
commit64d3fec76c913bf94f9b87f7482669302af9bbf9 (patch)
tree8dbf2fcf4a9bdabf6b0eaf5e2a27dd2171e36d37 /meson.build
parentRevert "main-loop: Disable block backend global state assertion on Cocoa" (diff)
downloadqemu-64d3fec76c913bf94f9b87f7482669302af9bbf9.tar.gz
qemu-64d3fec76c913bf94f9b87f7482669302af9bbf9.tar.xz
qemu-64d3fec76c913bf94f9b87f7482669302af9bbf9.zip
meson: Allow to enable gtk and sdl while cocoa is enabled
As ui/cocoa does no longer override main(), ui/gtk and ui/sdl can be enabled even ui/cocoa is enabled. Signed-off-by: Akihiko Odaki <akihiko.odaki@gmail.com> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Paolo Bonzini <pbonzini@redhat.com> Message-Id: <20220819132756.74641-4-akihiko.odaki@gmail.com> Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 3885fc1076..d9ac91ff36 100644
--- a/meson.build
+++ b/meson.build
@@ -589,12 +589,6 @@ endif
cocoa = dependency('appleframeworks', modules: ['Cocoa', 'CoreVideo'],
required: get_option('cocoa'))
-if cocoa.found() and get_option('sdl').enabled()
- error('Cocoa and SDL cannot be enabled at the same time')
-endif
-if cocoa.found() and get_option('gtk').enabled()
- error('Cocoa and GTK+ cannot be enabled at the same time')
-endif
vmnet = dependency('appleframeworks', modules: 'vmnet', required: get_option('vmnet'))
if vmnet.found() and not cc.has_header_symbol('vmnet/vmnet.h',
@@ -921,7 +915,7 @@ if not get_option('brlapi').auto() or have_system
endif
sdl = not_found
-if not get_option('sdl').auto() or (have_system and not cocoa.found())
+if not get_option('sdl').auto() or have_system
sdl = dependency('sdl2', required: get_option('sdl'), kwargs: static_kwargs)
sdl_image = not_found
endif
@@ -1187,7 +1181,7 @@ endif
gtk = not_found
gtkx11 = not_found
vte = not_found
-if not get_option('gtk').auto() or (have_system and not cocoa.found())
+if not get_option('gtk').auto() or have_system
gtk = dependency('gtk+-3.0', version: '>=3.22.0',
method: 'pkg-config',
required: get_option('gtk'),