summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2021-09-07 14:19:13 +0200
committerPaolo Bonzini2021-09-30 15:30:25 +0200
commit653163fcbcab72499ff1c2011f3552811d957729 (patch)
treef58457f9c50e24399573c3cbbc4f9b624cce1bae /meson.build
parentmemory: Add tracepoint for dirty sync (diff)
downloadqemu-653163fcbcab72499ff1c2011f3552811d957729.tar.gz
qemu-653163fcbcab72499ff1c2011f3552811d957729.tar.xz
qemu-653163fcbcab72499ff1c2011f3552811d957729.zip
build-sys: add HAVE_IPPROTO_MPTCP
The QAPI schema shouldn't rely on C system headers #define, but on configure-time project #define, so we can express the build condition in a C-independent way. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20210907121943.3498701-3-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fbdab3063b..60f4f45165 100644
--- a/meson.build
+++ b/meson.build
@@ -1374,6 +1374,8 @@ config_host_data.set('HAVE_OPTRESET',
cc.has_header_symbol('getopt.h', 'optreset'))
config_host_data.set('HAVE_UTMPX',
cc.has_header_symbol('utmpx.h', 'struct utmpx'))
+config_host_data.set('HAVE_IPPROTO_MPTCP',
+ cc.has_header_symbol('netinet/in.h', 'IPPROTO_MPTCP'))
# has_member
config_host_data.set('HAVE_SIGEV_NOTIFY_THREAD_ID',