summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-11-17 14:46:21 +0100
committerPaolo Bonzini2021-01-06 10:21:20 +0100
commit69202b406e3a42621a063c3afe80f580d343f59e (patch)
treee06350904996d95fef51d842a61ce99fe04819a8 /meson.build
parentseccomp: convert to meson (diff)
downloadqemu-69202b406e3a42621a063c3afe80f580d343f59e.tar.gz
qemu-69202b406e3a42621a063c3afe80f580d343f59e.tar.xz
qemu-69202b406e3a42621a063c3afe80f580d343f59e.zip
virtfs: convert to meson
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 22 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 55c3969fab..00d8a1d3e9 100644
--- a/meson.build
+++ b/meson.build
@@ -964,6 +964,25 @@ endif
# config-host.h #
#################
+have_virtfs = (targetos == 'linux' and
+ have_system and
+ libattr.found() and
+ libcap_ng.found())
+
+if get_option('virtfs').enabled()
+ if not have_virtfs
+ if targetos != 'linux'
+ error('virtio-9p (virtfs) requires Linux')
+ elif not libcap_ng.found() or not libattr.found()
+ error('virtio-9p (virtfs) requires libcap-ng-devel and libattr-devel')
+ elif not have_system
+ error('virtio-9p (virtfs) needs system emulation support')
+ endif
+ endif
+elif get_option('virtfs').disabled()
+ have_virtfs = false
+endif
+
config_host_data.set_quoted('CONFIG_BINDIR', get_option('prefix') / get_option('bindir'))
config_host_data.set_quoted('CONFIG_PREFIX', get_option('prefix'))
config_host_data.set_quoted('CONFIG_QEMU_CONFDIR', get_option('prefix') / qemu_confdir)
@@ -1006,6 +1025,7 @@ config_host_data.set('CONFIG_VNC', vnc.found())
config_host_data.set('CONFIG_VNC_JPEG', jpeg.found())
config_host_data.set('CONFIG_VNC_PNG', png.found())
config_host_data.set('CONFIG_VNC_SASL', sasl.found())
+config_host_data.set('CONFIG_VIRTFS', have_virtfs)
config_host_data.set('CONFIG_XKBCOMMON', xkbcommon.found())
config_host_data.set('CONFIG_KEYUTILS', keyutils.found())
config_host_data.set('CONFIG_GETTID', has_gettid)
@@ -1104,7 +1124,7 @@ host_kconfig = \
('CONFIG_VHOST_USER' in config_host ? ['CONFIG_VHOST_USER=y'] : []) + \
('CONFIG_VHOST_VDPA' in config_host ? ['CONFIG_VHOST_VDPA=y'] : []) + \
('CONFIG_VHOST_KERNEL' in config_host ? ['CONFIG_VHOST_KERNEL=y'] : []) + \
- ('CONFIG_VIRTFS' in config_host ? ['CONFIG_VIRTFS=y'] : []) + \
+ (have_virtfs ? ['CONFIG_VIRTFS=y'] : []) + \
('CONFIG_LINUX' in config_host ? ['CONFIG_LINUX=y'] : []) + \
('CONFIG_PVRDMA' in config_host ? ['CONFIG_PVRDMA=y'] : [])
@@ -2293,7 +2313,7 @@ summary_info += {'mingw32 support': targetos == 'windows'}
summary_info += {'Audio drivers': config_host['CONFIG_AUDIO_DRIVERS']}
summary_info += {'Block whitelist (rw)': config_host['CONFIG_BDRV_RW_WHITELIST']}
summary_info += {'Block whitelist (ro)': config_host['CONFIG_BDRV_RO_WHITELIST']}
-summary_info += {'VirtFS support': config_host.has_key('CONFIG_VIRTFS')}
+summary_info += {'VirtFS support': have_virtfs}
summary_info += {'build virtiofs daemon': have_virtiofsd}
summary_info += {'Multipath support': mpathpersist.found()}
summary_info += {'VNC support': vnc.found()}