summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-03 15:01:35 +0200
committerPaolo Bonzini2021-07-06 08:33:51 +0200
commit6d7c7c2d1d95cc6cdb56706bfa0446ad68e2b952 (patch)
treec793ef3e9e0b87844909e6bc2797a6bf63ec9963 /meson.build
parentmeson: sort existing compiler tests (diff)
downloadqemu-6d7c7c2d1d95cc6cdb56706bfa0446ad68e2b952.tar.gz
qemu-6d7c7c2d1d95cc6cdb56706bfa0446ad68e2b952.tar.xz
qemu-6d7c7c2d1d95cc6cdb56706bfa0446ad68e2b952.zip
meson: store dependency('threads') in a variable
It can be useful for has_function checks. Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53dfc2b4c6..e288e4c21c 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,7 @@ endif
multiprocess_allowed = targetos == 'linux' and not get_option('multiprocess').disabled()
libm = cc.find_library('m', required: false)
+threads = dependency('threads')
util = cc.find_library('util', required: false)
winmm = []
socket = []
@@ -1999,7 +2000,7 @@ util_ss.add_all(trace_ss)
util_ss = util_ss.apply(config_all, strict: false)
libqemuutil = static_library('qemuutil',
sources: util_ss.sources() + stub_ss.sources() + genh,
- dependencies: [util_ss.dependencies(), libm, glib, socket, malloc, pixman])
+ dependencies: [util_ss.dependencies(), libm, threads, glib, socket, malloc, pixman])
qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)