summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNicolas Saenz Julienne2022-04-25 09:57:22 +0200
committerStefan Hajnoczi2022-05-09 11:43:23 +0200
commit70ac26b9e5ca8374bb3ef3f30b871726673c9f27 (patch)
tree5bd929a72c3e414ab5323da317ef3895cb2c2fbb /meson.build
parentIntroduce event-loop-base abstract class (diff)
downloadqemu-70ac26b9e5ca8374bb3ef3f30b871726673c9f27.tar.gz
qemu-70ac26b9e5ca8374bb3ef3f30b871726673c9f27.tar.xz
qemu-70ac26b9e5ca8374bb3ef3f30b871726673c9f27.zip
util/main-loop: Introduce the main loop into QOM
'event-loop-base' provides basic property handling for all 'AioContext' based event loops. So let's define a new 'MainLoopClass' that inherits from it. This will permit tweaking the main loop's properties through qapi as well as through the command line using the '-object' keyword[1]. Only one instance of 'MainLoopClass' might be created at any time. 'EventLoopBaseClass' learns a new callback, 'can_be_deleted()' so as to mark 'MainLoop' as non-deletable. [1] For example: -object main-loop,id=main-loop,aio-max-batch=<value> Signed-off-by: Nicolas Saenz Julienne <nsaenzju@redhat.com> Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com> Acked-by: Markus Armbruster <armbru@redhat.com> Message-id: 20220425075723.20019-3-nsaenzju@redhat.com Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 85c151bf6c..864e97945f 100644
--- a/meson.build
+++ b/meson.build
@@ -3053,7 +3053,8 @@ libqemuutil = static_library('qemuutil',
sources: util_ss.sources() + stub_ss.sources() + genh,
dependencies: [util_ss.dependencies(), libm, threads, glib, socket, malloc, pixman])
qemuutil = declare_dependency(link_with: libqemuutil,
- sources: genh + version_res)
+ sources: genh + version_res,
+ dependencies: [event_loop_base])
if have_system or have_user
decodetree = generator(find_program('scripts/decodetree.py'),