summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorVolker RĂ¼melin2020-08-29 12:41:58 +0200
committerPaolo Bonzini2020-09-01 07:51:52 +0200
commit7161a43395c19206f1536b94b72cf7a90677275b (patch)
treed992e35b59c93f3d72e7ed23802d88ffe36e89d5 /meson.build
parentblock: always link with zlib (diff)
downloadqemu-7161a43395c19206f1536b94b72cf7a90677275b.tar.gz
qemu-7161a43395c19206f1536b94b72cf7a90677275b.tar.xz
qemu-7161a43395c19206f1536b94b72cf7a90677275b.zip
meson: fix SDL2_image detection
Configure used to probe for SDL2_image in sdl_image_probe (). Meson should do the same. This fixes the following error on my system: Run-time dependency sdl2 found: YES 2.0.8 Found CMake: /usr/bin/cmake (3.17.0) Run-time dependency sdl-image found: NO (tried pkgconfig and cmake) ../qemu-master/meson.build:256:2: ERROR: Dependency "sdl-image" not found, tried pkgconfig and cmake A full log can be found at /home/ruemelin/rpmbuild/BUILD /qemu-5.1.50-build/meson-logs/meson-log.txt ERROR: meson setup failed Signed-off-by: Volker RĂ¼melin <vr_qemu@t-online.de> Message-Id: <20200829104158.7461-1-vr_qemu@t-online.de> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1e7aee85e3..3c919e32f1 100644
--- a/meson.build
+++ b/meson.build
@@ -248,7 +248,7 @@ if sdl.found()
# work around 2.0.8 bug
sdl = declare_dependency(compile_args: '-Wno-undef',
dependencies: sdl)
- sdl_image = dependency('sdl-image', required: get_option('sdl_image'),
+ sdl_image = dependency('SDL2_image', required: get_option('sdl_image'),
static: enable_static)
else
if get_option('sdl_image').enabled()