summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKatsuhiro Ueno2021-04-29 04:43:07 +0200
committerPaolo Bonzini2021-05-26 14:49:46 +0200
commit75eebe0b1f15464d19a39c4186bfabf328ab601a (patch)
tree83ceca73b33f1999408b1b70d25dd5282592183e /meson.build
parenttests/qtest/fuzz: Fix build failure (diff)
downloadqemu-75eebe0b1f15464d19a39c4186bfabf328ab601a.tar.gz
qemu-75eebe0b1f15464d19a39c4186bfabf328ab601a.tar.xz
qemu-75eebe0b1f15464d19a39c4186bfabf328ab601a.zip
meson: Set implicit_include_directories to false
Without this, libvixl cannot be compiled with macOS 11.3 SDK due to include file name conflict (usr/include/c++/v1/version conflicts with VERSION). Signed-off-by: Katsuhiro Ueno <uenobk@gmail.com> Message-Id: <CA+pCdY09+OQfXq3YmRNuQE59ACOq7Py2q4hqOwgq4PnepCXhTA@mail.gmail.com> Tested-by: Alexander Graf <agraf@csgraf.de> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 632b380738..20d7035e44 100644
--- a/meson.build
+++ b/meson.build
@@ -2145,6 +2145,7 @@ common_all = common_ss.apply(config_all, strict: false)
common_all = static_library('common',
build_by_default: false,
sources: common_all.sources() + genh,
+ implicit_include_directories: false,
dependencies: common_all.dependencies(),
name_suffix: 'fa')