summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorSam Li2022-09-24 16:48:15 +0200
committerKevin Wolf2022-10-27 20:14:11 +0200
commit7845e731471365663dea8e34338f93791d31ea44 (patch)
treec33cc0445a97d87d2fb0729d948a8b20cbfc1331 /meson.build
parentvvfat: allow spaces in file names (diff)
downloadqemu-7845e731471365663dea8e34338f93791d31ea44.tar.gz
qemu-7845e731471365663dea8e34338f93791d31ea44.tar.xz
qemu-7845e731471365663dea8e34338f93791d31ea44.zip
block/io_uring: revert "Use io_uring_register_ring_fd() to skip fd operations"
Resolves: https://gitlab.com/qemu-project/qemu/-/issues/1193 The commit "Use io_uring_register_ring_fd() to skip fd operations" broke when booting a guest with iothread and io_uring. That is because the io_uring_register_ring_fd() call is made from the main thread instead of IOThread where io_uring_submit() is called. It can not be guaranteed to register the ring fd in the correct thread or unregister the same ring fd if the IOThread is disabled. This optimization is not critical so we will revert previous commit. This reverts commit e2848bc574fe2715c694bf8fe9a1ba7f78a1125a and 77e3f038af1764983087e3551a0fde9951952c4d. Cc: qemu-stable@nongnu.org Signed-off-by: Sam Li <faithilikerun@gmail.com> Message-Id: <20220924144815.5591-1-faithilikerun@gmail.com> Reviewed-by: Stefano Garzarella <sgarzare@redhat.com> Tested-by: Dario Faggioli <dfaggioli@suse.com> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b686dfef75..44c1f92697 100644
--- a/meson.build
+++ b/meson.build
@@ -1839,7 +1839,6 @@ config_host_data.set('CONFIG_LIBNFS', libnfs.found())
config_host_data.set('CONFIG_LIBSSH', libssh.found())
config_host_data.set('CONFIG_LINUX_AIO', libaio.found())
config_host_data.set('CONFIG_LINUX_IO_URING', linux_io_uring.found())
-config_host_data.set('CONFIG_LIBURING_REGISTER_RING_FD', cc.has_function('io_uring_register_ring_fd', prefix: '#include <liburing.h>', dependencies:linux_io_uring))
config_host_data.set('CONFIG_LIBPMEM', libpmem.found())
config_host_data.set('CONFIG_NUMA', numa.found())
config_host_data.set('CONFIG_OPENGL', opengl.found())