summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-01 10:00:48 +0200
committerPaolo Bonzini2021-06-04 13:47:07 +0200
commit7fa1c63553242ad557c26dafd01e828ff1507c64 (patch)
tree9bf25f6ed6825e86fd0cb686c4e6a13aadd5d3ad /meson.build
parentmeson: allow optional dependencies for block modules (diff)
downloadqemu-7fa1c63553242ad557c26dafd01e828ff1507c64.tar.gz
qemu-7fa1c63553242ad557c26dafd01e828ff1507c64.tar.xz
qemu-7fa1c63553242ad557c26dafd01e828ff1507c64.zip
iscsi: link libm into the module
Depending on the configuration of QEMU, some binaries might not need libm at all. In that case libiscsi, which uses exp(), will fail to load. Link it in the module explicitly. Reported-by: Yi Sun <yisun@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a45f1a844f..913cf2a41a 100644
--- a/meson.build
+++ b/meson.build
@@ -163,7 +163,7 @@ if targetos != 'linux' and get_option('multiprocess').enabled()
endif
multiprocess_allowed = targetos == 'linux' and not get_option('multiprocess').disabled()
-m = cc.find_library('m', required: false)
+libm = cc.find_library('m', required: false)
util = cc.find_library('util', required: false)
winmm = []
socket = []
@@ -1899,7 +1899,7 @@ util_ss.add_all(trace_ss)
util_ss = util_ss.apply(config_all, strict: false)
libqemuutil = static_library('qemuutil',
sources: util_ss.sources() + stub_ss.sources() + genh,
- dependencies: [util_ss.dependencies(), m, glib, socket, malloc, pixman])
+ dependencies: [util_ss.dependencies(), libm, glib, socket, malloc, pixman])
qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)