summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Bennée2021-07-07 15:17:43 +0200
committerPaolo Bonzini2021-07-09 18:21:34 +0200
commit812b31d3f91507160c367440c17715b62d5e0869 (patch)
treeffc92f2423f723212fbf776f6d48f128a0c1db59 /meson.build
parenthw/arm: move CONFIG_V7M out of default-devices (diff)
downloadqemu-812b31d3f91507160c367440c17715b62d5e0869.tar.gz
qemu-812b31d3f91507160c367440c17715b62d5e0869.tar.xz
qemu-812b31d3f91507160c367440c17715b62d5e0869.zip
configs: rename default-configs to configs and reorganise
In preparation for offering variation to our build configurations lets move everything and rename it to default. Common included base configs are also renamed. During the cleanup the stale usb.mak and pci.mak references were removed from MAINTAINERS. Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Cc: Paolo Bonzini <pbonzini@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20210707131744.26027-5-alex.bennee@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d82f7a789d..71c7462e89 100644
--- a/meson.build
+++ b/meson.build
@@ -1549,7 +1549,7 @@ foreach target : target_dirs
endif
actual_target_dirs += target
- config_target += keyval.load('default-configs/targets' / target + '.mak')
+ config_target += keyval.load('configs/targets' / target + '.mak')
config_target += { 'TARGET_' + config_target['TARGET_ARCH'].to_upper(): 'y' }
if 'TARGET_NEED_FDT' in config_target
@@ -1597,7 +1597,7 @@ foreach target : target_dirs
if target.endswith('-softmmu')
config_devices_mak = target + '-config-devices.mak'
config_devices_mak = configure_file(
- input: ['default-configs/devices' / target + '.mak', 'Kconfig'],
+ input: ['configs/devices' / target / 'default.mak', 'Kconfig'],
output: config_devices_mak,
depfile: config_devices_mak + '.d',
capture: true,