summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-03 11:31:35 +0200
committerPaolo Bonzini2021-07-06 08:33:51 +0200
commit83ef16821a41e540cec7a282374dcbfc1b2b0851 (patch)
treea4a23857c72f372d1aaf2f503c5eeb405573f25d /meson.build
parentconfigure, meson: convert virgl detection to meson (diff)
downloadqemu-83ef16821a41e540cec7a282374dcbfc1b2b0851.tar.gz
qemu-83ef16821a41e540cec7a282374dcbfc1b2b0851.tar.xz
qemu-83ef16821a41e540cec7a282374dcbfc1b2b0851.zip
configure, meson: convert libdaxctl detection to meson
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 84ffdb4599..e530829105 100644
--- a/meson.build
+++ b/meson.build
@@ -1011,8 +1011,10 @@ if 'CONFIG_LIBPMEM' in config_host
link_args: config_host['LIBPMEM_LIBS'].split())
endif
libdaxctl = not_found
-if 'CONFIG_LIBDAXCTL' in config_host
- libdaxctl = declare_dependency(link_args: config_host['LIBDAXCTL_LIBS'].split())
+if not get_option('libdaxctl').auto() or have_system
+ libdaxctl = dependency('libdaxctl', required: get_option('libdaxctl'),
+ version: '>=57', method: 'pkg-config',
+ kwargs: static_kwargs)
endif
tasn1 = not_found
if gnutls.found()
@@ -2821,7 +2823,7 @@ summary_info += {'NUMA host support': config_host.has_key('CONFIG_NUMA')}
summary_info += {'libxml2': config_host.has_key('CONFIG_LIBXML2')}
summary_info += {'capstone': capstone_opt == 'disabled' ? false : capstone_opt}
summary_info += {'libpmem support': config_host.has_key('CONFIG_LIBPMEM')}
-summary_info += {'libdaxctl support': config_host.has_key('CONFIG_LIBDAXCTL')}
+summary_info += {'libdaxctl support': libdaxctl.found()}
summary_info += {'libudev': libudev.found()}
summary_info += {'FUSE lseek': fuse_lseek.found()}
summary(summary_info, bool_yn: true, section: 'Dependencies')