summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Bennée2022-09-29 13:42:22 +0200
committerAlex Bennée2022-10-06 12:53:41 +0200
commit842b42df2b5d3bf5ccbafba19dc756d531dcce23 (patch)
treeb39947f01e80813bbefaee3a89ea0ce0a376add0 /meson.build
parentsemihosting: update link to spec (diff)
downloadqemu-842b42df2b5d3bf5ccbafba19dc756d531dcce23.tar.gz
qemu-842b42df2b5d3bf5ccbafba19dc756d531dcce23.tar.xz
qemu-842b42df2b5d3bf5ccbafba19dc756d531dcce23.zip
gdbstub: move into its own sub directory
This is in preparation of future refactoring as well as cleaning up the source tree. Aside from the minor tweaks to meson and trace.h this is pure code motion. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20220929114231.583801-43-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 536e819c60..b686dfef75 100644
--- a/meson.build
+++ b/meson.build
@@ -2863,6 +2863,7 @@ trace_events_subdirs = [
'qom',
'monitor',
'util',
+ 'gdbstub',
]
if have_linux_user
trace_events_subdirs += [ 'linux-user' ]
@@ -2986,6 +2987,7 @@ subdir('authz')
subdir('crypto')
subdir('ui')
subdir('hw')
+subdir('gdbstub')
if enable_modules
@@ -3063,7 +3065,7 @@ common_ss.add(files('cpus-common.c'))
subdir('softmmu')
common_ss.add(capstone)
-specific_ss.add(files('cpu.c', 'disas.c', 'gdbstub.c'), capstone)
+specific_ss.add(files('cpu.c', 'disas.c'), capstone)
# Work around a gcc bug/misfeature wherein constant propagation looks
# through an alias: