summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Graf2021-09-16 17:54:02 +0200
committerPeter Maydell2021-09-21 17:28:26 +0200
commit844a06bbe41d22b1ccd445e5351fb7429e49f0b7 (patch)
treeb3e4d4fdde087a1dea6e60c4154991a68c734da7 /meson.build
parenthvf: arm: Implement PSCI handling (diff)
downloadqemu-844a06bbe41d22b1ccd445e5351fb7429e49f0b7.tar.gz
qemu-844a06bbe41d22b1ccd445e5351fb7429e49f0b7.tar.xz
qemu-844a06bbe41d22b1ccd445e5351fb7429e49f0b7.zip
arm: Add Hypervisor.framework build target
Now that we have all logic in place that we need to handle Hypervisor.framework on Apple Silicon systems, let's add CONFIG_HVF for aarch64 as well so that we can build it. Signed-off-by: Alexander Graf <agraf@csgraf.de> Reviewed-by: Roman Bolshakov <r.bolshakov@yadro.com> Tested-by: Roman Bolshakov <r.bolshakov@yadro.com> (x86 only) Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Sergio Lopez <slp@redhat.com> Message-id: 20210916155404.86958-9-agraf@csgraf.de Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index baa28d7d62..15ef4d3c41 100644
--- a/meson.build
+++ b/meson.build
@@ -77,6 +77,13 @@ else
endif
accelerator_targets = { 'CONFIG_KVM': kvm_targets }
+
+if cpu in ['aarch64']
+ accelerator_targets += {
+ 'CONFIG_HVF': ['aarch64-softmmu']
+ }
+endif
+
if cpu in ['x86', 'x86_64', 'arm', 'aarch64']
# i386 emulator provides xenpv machine type for multiple architectures
accelerator_targets += {