summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMax Reitz2020-11-02 17:18:55 +0100
committerDr. David Alan Gilbert2020-11-02 20:22:49 +0100
commit84e319a575d04e9d53c24d801572a3ead538f9e4 (patch)
tree223eca94ac28fc2ccb0c0b9fad8fff2fa143ec0b /meson.build
parentvirtiofsd: Add attr_flags to fuse_entry_param (diff)
downloadqemu-84e319a575d04e9d53c24d801572a3ead538f9e4.tar.gz
qemu-84e319a575d04e9d53c24d801572a3ead538f9e4.tar.xz
qemu-84e319a575d04e9d53c24d801572a3ead538f9e4.zip
meson.build: Check for statx()
Check whether the glibc provides statx() and if so, define CONFIG_STATX. Signed-off-by: Max Reitz <mreitz@redhat.com> Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com> Message-Id: <20201102161859.156603-4-mreitz@redhat.com> Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 47e32e1fcb..39ac5cf6d8 100644
--- a/meson.build
+++ b/meson.build
@@ -736,6 +736,21 @@ if not has_malloc_trim and get_option('malloc_trim').enabled()
endif
endif
+# Check whether the glibc provides statx()
+
+statx_test = '''
+ #ifndef _GNU_SOURCE
+ #define _GNU_SOURCE
+ #endif
+ #include <sys/stat.h>
+ int main(void) {
+ struct statx statxbuf;
+ statx(0, "", 0, STATX_BASIC_STATS, &statxbuf);
+ return 0;
+ }'''
+
+has_statx = cc.links(statx_test)
+
#################
# config-host.h #
#################
@@ -768,6 +783,7 @@ config_host_data.set('CONFIG_XKBCOMMON', xkbcommon.found())
config_host_data.set('CONFIG_KEYUTILS', keyutils.found())
config_host_data.set('CONFIG_GETTID', has_gettid)
config_host_data.set('CONFIG_MALLOC_TRIM', has_malloc_trim)
+config_host_data.set('CONFIG_STATX', has_statx)
config_host_data.set('QEMU_VERSION', '"@0@"'.format(meson.project_version()))
config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0])
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])