summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorHongren (Zenithal) Zheng2022-05-19 14:38:57 +0200
committerGerd Hoffmann2022-06-14 10:34:36 +0200
commit8caef8507809634fc70ecb1faa898a0edaf1ae5c (patch)
tree636d7d4dbebb1a4fa08c3ab76ff7d78002a0acea /meson.build
parenthw/usb/canokey: Add trace events (diff)
downloadqemu-8caef8507809634fc70ecb1faa898a0edaf1ae5c.tar.gz
qemu-8caef8507809634fc70ecb1faa898a0edaf1ae5c.tar.xz
qemu-8caef8507809634fc70ecb1faa898a0edaf1ae5c.zip
meson: Add CanoKey
Signed-off-by: Hongren (Zenithal) Zheng <i@zenithal.me> Message-Id: <YoY6YRD6cxH21mms@Sun> Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 21cd949082..0c2e11ff07 100644
--- a/meson.build
+++ b/meson.build
@@ -1408,6 +1408,12 @@ if have_system
method: 'pkg-config',
kwargs: static_kwargs)
endif
+canokey = not_found
+if have_system
+ canokey = dependency('canokey-qemu', required: get_option('canokey'),
+ method: 'pkg-config',
+ kwargs: static_kwargs)
+endif
usbredir = not_found
if not get_option('usb_redir').auto() or have_system
usbredir = dependency('libusbredirparser-0.5', required: get_option('usb_redir'),