summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-11-08 12:36:29 +0100
committerPaolo Bonzini2022-02-21 10:35:53 +0100
commit8cc2d231b30799b45ce477e6cb472124456df4a4 (patch)
tree7930a4b137a9075f99573e3284a2502a4d890090 /meson.build
parentconfigure, meson: move block layer options to meson_options.txt (diff)
downloadqemu-8cc2d231b30799b45ce477e6cb472124456df4a4.tar.gz
qemu-8cc2d231b30799b45ce477e6cb472124456df4a4.tar.xz
qemu-8cc2d231b30799b45ce477e6cb472124456df4a4.zip
meson: define qemu_cflags/qemu_ldflags
Prepare for moving more compiler tests to Meson. If the full set of compiler flags is needed in a cc.compiles/cc.links test, it will be handy to have a variable analogous to QEMU_CFLAGS. Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 7 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 031bbf468c..c520d6af68 100644
--- a/meson.build
+++ b/meson.build
@@ -163,6 +163,10 @@ endif
# Compiler flags #
##################
+qemu_cflags = config_host['QEMU_CFLAGS'].split()
+qemu_cxxflags = config_host['QEMU_CXXFLAGS'].split()
+qemu_ldflags = config_host['QEMU_LDFLAGS'].split()
+
# Specify linker-script with add_project_link_arguments so that it is not placed
# within a linker --start-group/--end-group pair
if get_option('fuzzing')
@@ -198,12 +202,9 @@ if get_option('fuzzing')
endif
endif
-add_global_arguments(config_host['QEMU_CFLAGS'].split(),
- native: false, language: ['c', 'objc'])
-add_global_arguments(config_host['QEMU_CXXFLAGS'].split(),
- native: false, language: 'cpp')
-add_global_link_arguments(config_host['QEMU_LDFLAGS'].split(),
- native: false, language: ['c', 'cpp', 'objc'])
+add_global_arguments(qemu_cflags, native: false, language: ['c', 'objc'])
+add_global_arguments(qemu_cxxflags, native: false, language: ['cpp'])
+add_global_link_arguments(qemu_ldflags, native: false, language: ['c', 'cpp', 'objc'])
if targetos == 'linux'
add_project_arguments('-isystem', meson.current_source_dir() / 'linux-headers',