summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann2021-07-23 14:01:56 +0200
committerPaolo Bonzini2021-07-23 15:45:52 +0200
commit917ddc27d86ae427d2aa7ff2d19eb7fdb642b68e (patch)
treed9470b24e09f366128240f010875f230b52a0ff7 /meson.build
parentMerge remote-tracking branch 'remotes/bonzini-gitlab/tags/for-upstream' into ... (diff)
downloadqemu-917ddc27d86ae427d2aa7ff2d19eb7fdb642b68e.tar.gz
qemu-917ddc27d86ae427d2aa7ff2d19eb7fdb642b68e.tar.xz
qemu-917ddc27d86ae427d2aa7ff2d19eb7fdb642b68e.zip
meson: fix dependencies for modinfo #2
modinfo runs the preprocessor and therefore needs all generated input files to be there. The "depends" clause does not work in Meson 0.55.3, so for now use "input". Part #2: Update the rule for target-specific modules too. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Message-Id: <20210723120156.1183920-1-kraxel@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index df5094e563..f2e148eaf9 100644
--- a/meson.build
+++ b/meson.build
@@ -2373,9 +2373,9 @@ foreach d, list : target_modules
# FIXME: Should use sl.extract_all_objects(recursive: true) too.
modinfo_files += custom_target(module_name + '.modinfo',
output: module_name + '.modinfo',
- input: target_module_ss.sources(),
+ input: target_module_ss.sources() + genh,
capture: true,
- command: [modinfo_collect, '--target', target, '@INPUT@'])
+ command: [modinfo_collect, '--target', target, target_module_ss.sources()])
endif
endif
endforeach