summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Vivier2020-08-24 17:24:30 +0200
committerGerd Hoffmann2020-08-25 08:12:19 +0200
commit9755c94a50c8b845ad133a6e660f55ca131b9c7a (patch)
tree953fe0c6e70b847cede8dfefee705a16ca38232c /meson.build
parentmeson: move xkbcommon to meson (diff)
downloadqemu-9755c94a50c8b845ad133a6e660f55ca131b9c7a.tar.gz
qemu-9755c94a50c8b845ad133a6e660f55ca131b9c7a.tar.xz
qemu-9755c94a50c8b845ad133a6e660f55ca131b9c7a.zip
meson: avoid compiling qemu-keymap by default
qemu-keymap is not needed with linux-user, so disable it by default if tools and system are disabled (tools are disabled by default with linux-user). Avoid this error with statically linked binaries: Linking target qemu-keymap /usr/bin/ld: cannot find -lxkbcommon Signed-off-by: Laurent Vivier <laurent@vivier.eu> Message-id: 20200824152430.1844159-3-laurent@vivier.eu Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f6e346af1a..f0fe5f8799 100644
--- a/meson.build
+++ b/meson.build
@@ -1063,6 +1063,11 @@ if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif
+# Don't build qemu-keymap if xkbcommon is not explicitly enabled
+# when we don't build tools or system
+if get_option('xkbcommon').auto() and not have_system and not have_tools
+ xkbcommon = not_found
+endif
if xkbcommon.found()
# used for the update-keymaps target, so include rules even if !have_tools
qemu_keymap = executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c') + genh,