summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorVikram Garhwal2020-11-18 20:48:43 +0100
committerPeter Maydell2020-12-10 12:30:44 +0100
commit98e5d7a2b726947081fe2733ec869f9aa967c890 (patch)
treedf45495c1e6c3c929aa1659cb1ef16ddf5902c03 /meson.build
parenthw/arm/smmuv3: Fix up L1STD_SPAN decoding (diff)
downloadqemu-98e5d7a2b726947081fe2733ec869f9aa967c890.tar.gz
qemu-98e5d7a2b726947081fe2733ec869f9aa967c890.tar.xz
qemu-98e5d7a2b726947081fe2733ec869f9aa967c890.zip
hw/net/can: Introduce Xilinx ZynqMP CAN controller
The Xilinx ZynqMP CAN controller is developed based on SocketCAN, QEMU CAN bus implementation. Bus connection and socketCAN connection for each CAN module can be set through command lines. Example for using single CAN: -object can-bus,id=canbus0 \ -machine xlnx-zcu102.canbus0=canbus0 \ -object can-host-socketcan,id=socketcan0,if=vcan0,canbus=canbus0 Example for connecting both CAN to same virtual CAN on host machine: -object can-bus,id=canbus0 -object can-bus,id=canbus1 \ -machine xlnx-zcu102.canbus0=canbus0 \ -machine xlnx-zcu102.canbus1=canbus1 \ -object can-host-socketcan,id=socketcan0,if=vcan0,canbus=canbus0 \ -object can-host-socketcan,id=socketcan1,if=vcan0,canbus=canbus1 To create virtual CAN on the host machine, please check the QEMU CAN docs: https://github.com/qemu/qemu/blob/master/docs/can.txt Signed-off-by: Vikram Garhwal <fnu.vikram@xilinx.com> Message-id: 1605728926-352690-2-git-send-email-fnu.vikram@xilinx.com Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 732b29a1f3..9ea05ab49f 100644
--- a/meson.build
+++ b/meson.build
@@ -1433,6 +1433,7 @@ if have_system
'hw/misc',
'hw/misc/macio',
'hw/net',
+ 'hw/net/can',
'hw/nvram',
'hw/pci',
'hw/pci-host',