summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-10-07 17:01:51 +0200
committerPaolo Bonzini2020-10-12 17:50:52 +0200
commita0c9162c8250e121af438aee5ef93e64ec62dae1 (patch)
treeb55ff4dc3e8012e2624d2aa2d1211684bd425656 /meson.build
parentscsi/scsi_bus: fix races in REPORT LUNS (diff)
downloadqemu-a0c9162c8250e121af438aee5ef93e64ec62dae1.tar.gz
qemu-a0c9162c8250e121af438aee5ef93e64ec62dae1.tar.xz
qemu-a0c9162c8250e121af438aee5ef93e64ec62dae1.zip
meson: identify more sections of meson.build
Add more headers that clarify code organization. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build36
1 files changed, 25 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index 0c676af194..652c37cceb 100644
--- a/meson.build
+++ b/meson.build
@@ -614,7 +614,9 @@ if not has_malloc_trim and get_option('malloc_trim').enabled()
endif
endif
-# Create config-host.h
+#################
+# config-host.h #
+#################
config_host_data.set('CONFIG_COCOA', cocoa.found())
config_host_data.set('CONFIG_LIBUDEV', libudev.found())
@@ -660,6 +662,10 @@ foreach k, v: config_host
endif
endforeach
+########################
+# Target configuration #
+########################
+
minikconf = find_program('scripts/minikconf.py')
config_all = {}
config_all_devices = {}
@@ -866,7 +872,9 @@ config_all += {
'CONFIG_ALL': true,
}
-# Submodules
+##############
+# Submodules #
+##############
capstone = not_found
capstone_opt = get_option('capstone')
@@ -1105,9 +1113,11 @@ config_host_data.set('CONFIG_CAPSTONE', capstone.found())
config_host_data.set('CONFIG_FDT', fdt.found())
config_host_data.set('CONFIG_SLIRP', slirp.found())
-genh += configure_file(output: 'config-host.h', configuration: config_host_data)
+#####################
+# Generated sources #
+#####################
-# Generators
+genh += configure_file(output: 'config-host.h', configuration: config_host_data)
hxtool = find_program('scripts/hxtool')
shaderinclude = find_program('scripts/shaderinclude.pl')
@@ -1182,7 +1192,9 @@ sphinx_extn_depends = [ meson.source_root() / 'docs/sphinx/depfile.py',
meson.source_root() / 'docs/sphinx/qmp_lexer.py',
qapi_gen_depends ]
-# Collect sourcesets.
+###################
+# Collect sources #
+###################
authz_ss = ss.source_set()
blockdev_ss = ss.source_set()
@@ -1320,8 +1332,6 @@ if enable_modules
modulecommon = declare_dependency(link_whole: libmodulecommon, compile_args: '-DBUILD_DSO')
endif
-# Build targets from sourcesets
-
stub_ss = stub_ss.apply(config_all, strict: false)
util_ss.add_all(trace_ss)
@@ -1409,6 +1419,10 @@ specific_ss.add_all(when: 'CONFIG_LINUX_USER', if_true: linux_user_ss)
subdir('tests/qtest/libqos')
subdir('tests/qtest/fuzz')
+########################
+# Library dependencies #
+########################
+
block_mods = []
softmmu_mods = []
foreach d, list : modules
@@ -1443,10 +1457,6 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
capture: true,
command: [undefsym, nm, '@INPUT@'])
-########################
-# Library dependencies #
-########################
-
qom_ss = qom_ss.apply(config_host, strict: false)
libqom = static_library('qom', qom_ss.sources() + genh,
dependencies: [qom_ss.dependencies()],
@@ -1797,6 +1807,10 @@ if host_machine.system() == 'windows'
alias_target('installer', nsis)
endif
+#########################
+# Configuration summary #
+#########################
+
summary_info = {}
summary_info += {'Install prefix': config_host['prefix']}
summary_info += {'BIOS directory': config_host['qemu_datadir']}