summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-07-12 14:22:08 +0200
committerAlex Bennée2021-07-14 15:31:48 +0200
commita1b176f9046a94ae963099a055cde2323dc7c012 (patch)
treea5229c117074e0f459ed0890e9e1fab6f928494a /meson.build
parentmeson: fix condition for io_uring stubs (diff)
downloadqemu-a1b176f9046a94ae963099a055cde2323dc7c012.tar.gz
qemu-a1b176f9046a94ae963099a055cde2323dc7c012.tar.xz
qemu-a1b176f9046a94ae963099a055cde2323dc7c012.zip
disable modular TCG on Darwin
Accelerator modularity does not work on Darwin: ld: illegal thread local variable reference to regular symbol _current_cpu for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) Fix by avoiding modular TCG builds. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com> Message-Id: <20210712122208.456264-1-pbonzini@redhat.com> [AJB: manually merged typo fix] Signed-off-by: Alex Bennée <alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b0e2b9a8a0..512ee2e926 100644
--- a/meson.build
+++ b/meson.build
@@ -92,7 +92,11 @@ if cpu in ['x86', 'x86_64']
}
endif
-modular_tcg = ['i386-softmmu', 'x86_64-softmmu']
+modular_tcg = []
+# Darwin does not support references to thread-local variables in modules
+if targetos != 'darwin'
+ modular_tcg = ['i386-softmmu', 'x86_64-softmmu']
+endif
edk2_targets = [ 'arm-softmmu', 'aarch64-softmmu', 'i386-softmmu', 'x86_64-softmmu' ]
install_edk2_blobs = false