summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBin Meng2022-09-08 15:28:13 +0200
committerStefan Weil2022-10-31 10:06:11 +0100
commita3c1e6458dbbe3647ccadfb39cbb585fdc4373a5 (patch)
treedb7d4f704001b83ffea578249c41fb32656290c9 /meson.build
parentscripts/nsis.py: Fix destination directory name when invoked on Windows (diff)
downloadqemu-a3c1e6458dbbe3647ccadfb39cbb585fdc4373a5.tar.gz
qemu-a3c1e6458dbbe3647ccadfb39cbb585fdc4373a5.tar.xz
qemu-a3c1e6458dbbe3647ccadfb39cbb585fdc4373a5.zip
scripts/nsis.py: Automatically package required DLLs of QEMU executables
At present packaging the required DLLs of QEMU executables is a manual process, and error prone. Actually build/config-host.mak contains a GLIB_BINDIR variable which is the directory where glib and other DLLs reside. This works for both Windows native build and cross-build on Linux. We can use it as the search directory for DLLs and automate the whole DLL packaging process. Signed-off-by: Bin Meng <bin.meng@windriver.com> Message-Id: <20220908132817.1831008-4-bmeng.cn@gmail.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Tested-by: Stefan Weil <sw@weilnetz.de> Signed-off-by: Stefan Weil <sw@weilnetz.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 37737913df..d0a186e7f5 100644
--- a/meson.build
+++ b/meson.build
@@ -3616,6 +3616,7 @@ if host_machine.system() == 'windows'
'@OUTPUT@',
get_option('prefix'),
meson.current_source_dir(),
+ config_host['GLIB_BINDIR'],
host_machine.cpu(),
'--',
'-DDISPLAYVERSION=' + meson.project_version(),