summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-09-01 11:32:23 +0200
committerPaolo Bonzini2020-09-08 11:43:16 +0200
commita98006bc798169e661d2e2f02f6efb105c55ffa0 (patch)
tree31e2ef6c3f13098d3664d8ec8c905ac65ea99869 /meson.build
parentconfigure: remove dead code for in-tree builds (diff)
downloadqemu-a98006bc798169e661d2e2f02f6efb105c55ffa0.tar.gz
qemu-a98006bc798169e661d2e2f02f6efb105c55ffa0.tar.xz
qemu-a98006bc798169e661d2e2f02f6efb105c55ffa0.zip
meson: compute config_all_devices directly
There is no need anymore to produce config-all-devices.mak, compute the resulting dictionary directly instead of going through grepy.sh. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 2 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 3b73731bab..a6df2695a8 100644
--- a/meson.build
+++ b/meson.build
@@ -460,6 +460,7 @@ endforeach
genh += configure_file(output: 'config-host.h', configuration: config_host_data)
minikconf = find_program('scripts/minikconf.py')
+config_all_devices = {}
config_devices_mak_list = []
config_devices_h = {}
config_target_h = {}
@@ -528,11 +529,11 @@ foreach target : target_dirs
config_devices_h += {target: configure_file(output: target + '-config-devices.h',
configuration: config_devices_data)}
config_target += config_devices
+ config_all_devices += config_devices
endif
config_target_mak += {target: config_target}
endforeach
-grepy = find_program('scripts/grepy.sh')
# This configuration is used to build files that are shared by
# multiple binaries, and then extracted out of the "common"
# static_library target.
@@ -542,17 +543,6 @@ grepy = find_program('scripts/grepy.sh')
# targets that are not built for this compilation. The CONFIG_ALL
# pseudo symbol replaces it.
-if have_system
- config_all_devices_mak = configure_file(
- output: 'config-all-devices.mak',
- input: config_devices_mak_list,
- capture: true,
- command: [grepy, '@INPUT@'],
- )
- config_all_devices = keyval.load(config_all_devices_mak)
-else
- config_all_devices = {}
-endif
config_all = config_all_devices
config_all += config_host
config_all += config_all_disas