summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2020-08-26 13:04:16 +0200
committerPaolo Bonzini2020-09-01 14:51:33 +0200
commitab4c0996f80d43d1fc28c6e76f4ecb27423a7e29 (patch)
tree62cbaf2a60cc5c3c47202dc62c112fe51e1e6a76 /meson.build
parentmeson: pass qemu_suffix option (diff)
downloadqemu-ab4c0996f80d43d1fc28c6e76f4ecb27423a7e29.tar.gz
qemu-ab4c0996f80d43d1fc28c6e76f4ecb27423a7e29.tar.xz
qemu-ab4c0996f80d43d1fc28c6e76f4ecb27423a7e29.zip
meson: use meson datadir instead of qemu_datadir
When cross-compiling, by default qemu_datadir is 'c:\Program Files\QEMU', which is not recognized as being an absolute path, and meson will end up adding the prefix again. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20200826110419.528931-6-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b68e1bdfc7..6bcfafbc1f 100644
--- a/meson.build
+++ b/meson.build
@@ -18,6 +18,7 @@ config_all_disas = keyval.load(meson.current_build_dir() / 'config-all-disas.mak
enable_modules = 'CONFIG_MODULES' in config_host
enable_static = 'CONFIG_STATIC' in config_host
build_docs = 'BUILD_DOCS' in config_host
+qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
config_host_data = configuration_data()
genh = []
@@ -1055,7 +1056,7 @@ foreach target : target_dirs
output: exe['name'] + stp['ext'],
capture: true,
install: stp['install'],
- install_dir: config_host['qemu_datadir'] / '../systemtap/tapset',
+ install_dir: qemu_datadir / '../systemtap/tapset',
command: [
tracetool, '--group=all', '--format=' + stp['fmt'],
'--binary=' + stp['bin'],