summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2020-08-28 13:07:25 +0200
committerPaolo Bonzini2020-09-08 11:43:16 +0200
commitaf04e89dd97a8098fe5643f6e9a28fa4233f21cf (patch)
treefa92b53259f9d03aa9b3a52d1dda48b5332cc649 /meson.build
parentmeson: convert the unit tests (diff)
downloadqemu-af04e89dd97a8098fe5643f6e9a28fa4233f21cf.tar.gz
qemu-af04e89dd97a8098fe5643f6e9a28fa4233f21cf.tar.xz
qemu-af04e89dd97a8098fe5643f6e9a28fa4233f21cf.zip
meson: move keyutils dependency check
Since there is not minimum version specified, and it's a test-only dependency, it's fair to depend on a version that ships with a .pc I suppose. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20200828110734.1638685-8-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index d3cf531297..f7cd2b6f73 100644
--- a/meson.build
+++ b/meson.build
@@ -415,10 +415,8 @@ if 'CONFIG_TASN1' in config_host
tasn1 = declare_dependency(compile_args: config_host['TASN1_CFLAGS'].split(),
link_args: config_host['TASN1_LIBS'].split())
endif
-keyutils = not_found
-if 'CONFIG_KEYUTILS' in config_host
- keyutils = declare_dependency(link_args: '-lkeyutils')
-endif
+keyutils = dependency('libkeyutils', required: false,
+ method: 'pkg-config', static: enable_static)
# Create config-host.h
@@ -429,6 +427,7 @@ config_host_data.set('CONFIG_VNC_JPEG', jpeg.found())
config_host_data.set('CONFIG_VNC_PNG', png.found())
config_host_data.set('CONFIG_VNC_SASL', sasl.found())
config_host_data.set('CONFIG_XKBCOMMON', xkbcommon.found())
+config_host_data.set('CONFIG_KEYUTILS', keyutils.found())
config_host_data.set('QEMU_VERSION', '"@0@"'.format(meson.project_version()))
config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0])
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])