summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-16 19:37:25 +0200
committerPaolo Bonzini2020-08-21 12:30:18 +0200
commitb7c70bf2c521c85e2ec575705465e657a6f412c4 (patch)
tree2e75e9c66b979b5ffe95ecf56ecdd0e8cc8ee162 /meson.build
parentmeson: convert block (diff)
downloadqemu-b7c70bf2c521c85e2ec575705465e657a6f412c4.tar.gz
qemu-b7c70bf2c521c85e2ec575705465e657a6f412c4.tar.xz
qemu-b7c70bf2c521c85e2ec575705465e657a6f412c4.zip
meson: qemu-{img,io,nbd}
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1d301948b7..7f753afc6e 100644
--- a/meson.build
+++ b/meson.build
@@ -350,7 +350,7 @@ if have_system
]
endif
foreach d : hx_headers
- custom_target(d[1],
+ hxdep += custom_target(d[1],
input: files(d[0]),
output: d[1],
capture: true,
@@ -559,7 +559,8 @@ libblock = static_library('block', block_ss.sources() + genh,
build_by_default: false)
block = declare_dependency(link_whole: [libblock],
- link_args: '@block.syms')
+ link_args: '@block.syms',
+ dependencies: [crypto, io])
foreach m : block_mods + softmmu_mods
shared_module(m.name(),
@@ -637,6 +638,15 @@ if 'CONFIG_GUEST_AGENT' in config_host
endif
if have_tools
+ qemu_img = executable('qemu-img', [files('qemu-img.c'), hxdep],
+ dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)
+ qemu_io = executable('qemu-io', files('qemu-io.c'),
+ dependencies: [block, qemuutil], install: true)
+ if targetos == 'linux' or targetos == 'sunos' or targetos.endswith('bsd')
+ qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
+ dependencies: [block, qemuutil], install: true)
+ endif
+
subdir('contrib/rdmacm-mux')
subdir('contrib/elf2dmp')