summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-01-21 11:49:04 +0100
committerPaolo Bonzini2021-01-23 21:55:05 +0100
commitb846ab7c9593197367361fb1110586ba4d311c23 (patch)
tree6d8e0293585ffc476569008d4ccf7b6abd2b754e /meson.build
parentnsis: adjust for new MinGW paths (diff)
downloadqemu-b846ab7c9593197367361fb1110586ba4d311c23.tar.gz
qemu-b846ab7c9593197367361fb1110586ba4d311c23.tar.xz
qemu-b846ab7c9593197367361fb1110586ba4d311c23.zip
meson: convert wixl detection to Meson
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 4f0e459243..430942c8b4 100644
--- a/meson.build
+++ b/meson.build
@@ -2196,6 +2196,8 @@ endif
if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
+elif get_option('guest_agent_msi').enabled()
+ error('Guest agent MSI requested, but the guest agent is not being built')
endif
# Don't build qemu-keymap if xkbcommon is not explicitly enabled
@@ -2460,9 +2462,11 @@ if targetos == 'windows'
if 'WIN_SDK' in config_host
summary_info += {'Windows SDK': config_host['WIN_SDK']}
endif
- summary_info += {'QGA VSS support': config_host.has_key('CONFIG_QGA_VSS')}
- summary_info += {'QGA w32 disk info': config_host.has_key('CONFIG_QGA_NTDDSCSI')}
- summary_info += {'QGA MSI support': config_host.has_key('CONFIG_QGA_MSI')}
+ if config_host.has_key('CONFIG_GUEST_AGENT')
+ summary_info += {'QGA VSS support': config_host.has_key('CONFIG_QGA_VSS')}
+ summary_info += {'QGA w32 disk info': config_host.has_key('CONFIG_QGA_NTDDSCSI')}
+ summary_info += {'QGA MSI support': wixl.found()}
+ endif
endif
summary_info += {'seccomp support': seccomp.found()}
summary_info += {'CFI support': get_option('cfi')}