summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Hajnoczi2020-08-25 08:49:53 +0200
committerPaolo Bonzini2020-08-27 18:52:22 +0200
commitbd5f973ac22046d1cd532847630e9ee10ebd8d76 (patch)
treed9a234e5c449fc0855d3c292b395907145010775 /meson.build
parentMerge remote-tracking branch 'remotes/berrange/tags/socket-next-pull-request'... (diff)
downloadqemu-bd5f973ac22046d1cd532847630e9ee10ebd8d76.tar.gz
qemu-bd5f973ac22046d1cd532847630e9ee10ebd8d76.tar.xz
qemu-bd5f973ac22046d1cd532847630e9ee10ebd8d76.zip
trace: fix creation of systemtap files
The "exe_name" variable was renamed to exe['name'], so systemtap files fail to build. Reported-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index f0fe5f8799..f2aa5a7700 100644
--- a/meson.build
+++ b/meson.build
@@ -1029,14 +1029,14 @@ foreach target : target_dirs
if 'CONFIG_TRACE_SYSTEMTAP' in config_host
foreach stp: [
- {'ext': '.stp-build', 'fmt': 'stap', 'bin': meson.current_build_dir() / exe_name, 'install': false},
- {'ext': '.stp', 'fmt': 'stap', 'bin': get_option('prefix') / get_option('bindir') / exe_name, 'install': true},
+ {'ext': '.stp-build', 'fmt': 'stap', 'bin': meson.current_build_dir() / exe['name'], 'install': false},
+ {'ext': '.stp', 'fmt': 'stap', 'bin': get_option('prefix') / get_option('bindir') / exe['name'], 'install': true},
{'ext': '-simpletrace.stp', 'fmt': 'simpletrace-stap', 'bin': '', 'install': true},
{'ext': '-log.stp', 'fmt': 'log-stap', 'bin': '', 'install': true},
]
- custom_target(exe_name + stp['ext'],
+ custom_target(exe['name'] + stp['ext'],
input: trace_events_all,
- output: exe_name + stp['ext'],
+ output: exe['name'] + stp['ext'],
capture: true,
install: stp['install'],
install_dir: config_host['qemu_datadir'] / '../systemtap/tapset',