summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Hajnoczi2020-08-27 16:29:12 +0200
committerStefan Hajnoczi2021-01-04 15:24:58 +0100
commitc05012a365c2d7d42d205b1efa895bf2144bab88 (patch)
treeb7a25025de22f351f41d84dfdf621d16dc87fa3b /meson.build
parenttrace: Send "-d trace:help" output to stdout (diff)
downloadqemu-c05012a365c2d7d42d205b1efa895bf2144bab88.tar.gz
qemu-c05012a365c2d7d42d205b1efa895bf2144bab88.tar.xz
qemu-c05012a365c2d7d42d205b1efa895bf2144bab88.zip
tracetool: add output filename command-line argument
The tracetool.py script writes to stdout. This means the output filename is not available to the script. Add the output filename to the command-line so that the script has access to the filename. This also simplifies the tracetool.py invocation. It's no longer necessary to use meson's custom_build(capture : true) to save output. Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Message-Id: <20200827142915.108730-2-stefanha@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 372576f82c..4a92213231 100644
--- a/meson.build
+++ b/meson.build
@@ -1901,7 +1901,6 @@ foreach target : target_dirs
custom_target(exe['name'] + stp['ext'],
input: trace_events_all,
output: exe['name'] + stp['ext'],
- capture: true,
install: stp['install'],
install_dir: get_option('datadir') / 'systemtap/tapset',
command: [
@@ -1910,7 +1909,7 @@ foreach target : target_dirs
'--target-name=' + target_name,
'--target-type=' + target_type,
'--probe-prefix=qemu.' + target_type + '.' + target_name,
- '@INPUT@',
+ '@INPUT@', '@OUTPUT@'
])
endforeach
endif