summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-03 11:31:35 +0200
committerPaolo Bonzini2021-07-06 08:33:51 +0200
commitc23d7b4e570ce7e63042a60f0747595f515c6822 (patch)
tree40e409a826254dcf873251d1a7a50e6383a32a0a /meson.build
parentconfigure: drop vte-2.90 check (diff)
downloadqemu-c23d7b4e570ce7e63042a60f0747595f515c6822.tar.gz
qemu-c23d7b4e570ce7e63042a60f0747595f515c6822.tar.xz
qemu-c23d7b4e570ce7e63042a60f0747595f515c6822.zip
configure, meson: convert vte detection to meson
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 10 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index db6789af9c..b15c1ee4fd 100644
--- a/meson.build
+++ b/meson.build
@@ -860,6 +860,7 @@ endif
gtk = not_found
gtkx11 = not_found
+vte = not_found
if not get_option('gtk').auto() or (have_system and not cocoa.found())
gtk = dependency('gtk+-3.0', version: '>=3.22.0',
method: 'pkg-config',
@@ -871,14 +872,16 @@ if not get_option('gtk').auto() or (have_system and not cocoa.found())
required: false,
kwargs: static_kwargs)
gtk = declare_dependency(dependencies: [gtk, gtkx11])
+
+ if not get_option('vte').auto() or have_system
+ vte = dependency('vte-2.91',
+ method: 'pkg-config',
+ required: get_option('vte'),
+ kwargs: static_kwargs)
+ endif
endif
endif
-vte = not_found
-if 'CONFIG_VTE' in config_host
- vte = declare_dependency(compile_args: config_host['VTE_CFLAGS'].split(),
- link_args: config_host['VTE_LIBS'].split())
-endif
x11 = not_found
if gtkx11.found()
x11 = dependency('x11', method: 'pkg-config', required: gtkx11.found(),
@@ -1208,6 +1211,7 @@ if glusterfs.found()
config_host_data.set('CONFIG_GLUSTERFS_IOCB_HAS_STAT', glusterfs_iocb_has_stat)
endif
config_host_data.set('CONFIG_GTK', gtk.found())
+config_host_data.set('CONFIG_VTE', vte.found())
config_host_data.set('CONFIG_LIBATTR', have_old_libattr)
config_host_data.set('CONFIG_LIBCAP_NG', libcap_ng.found())
config_host_data.set('CONFIG_EBPF', libbpf.found())
@@ -2756,7 +2760,7 @@ summary_info += {'SDL image support': sdl_image.found()}
summary_info += {'GTK support': gtk.found()}
summary_info += {'pixman': pixman.found()}
# TODO: add back version
-summary_info += {'VTE support': config_host.has_key('CONFIG_VTE')}
+summary_info += {'VTE support': vte.found()}
# TODO: add back version
summary_info += {'slirp support': slirp_opt == 'disabled' ? false : slirp_opt}
summary_info += {'libtasn1': tasn1.found()}