summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2022-02-08 11:19:46 +0100
committerPhilippe Mathieu-Daudé2022-03-06 13:15:42 +0100
commitc593d841f879d02c589f99c79f1f21c44b789042 (patch)
tree607a86e05718b57a005674c1b28c08bcfea39f33 /meson.build
parentsoftmmu: Build target-agnostic objects once (diff)
downloadqemu-c593d841f879d02c589f99c79f1f21c44b789042.tar.gz
qemu-c593d841f879d02c589f99c79f1f21c44b789042.tar.xz
qemu-c593d841f879d02c589f99c79f1f21c44b789042.zip
meson: Display libfdt as disabled when system emulation is disabled
When configuring QEMU with --disable-system, meson keeps showing libfdt as "auto". Mark it as disabled instead. Acked-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20220214183144.27402-2-f4bug@amsat.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 038502714a..746ce478e0 100644
--- a/meson.build
+++ b/meson.build
@@ -2432,8 +2432,8 @@ if get_option('cfi') and slirp_opt == 'system'
endif
fdt = not_found
-fdt_opt = get_option('fdt')
if have_system
+ fdt_opt = get_option('fdt')
if fdt_opt in ['enabled', 'auto', 'system']
have_internal = fs.exists(meson.current_source_dir() / 'dtc/libfdt/Makefile.libfdt')
fdt = cc.find_library('fdt', kwargs: static_kwargs,
@@ -2476,6 +2476,8 @@ if have_system
fdt = declare_dependency(link_with: libfdt,
include_directories: fdt_inc)
endif
+else
+ fdt_opt = 'disabled'
endif
if not fdt.found() and fdt_required.length() > 0
error('fdt not available but required by targets ' + ', '.join(fdt_required))