summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Ivanov2022-10-17 09:28:19 +0200
committerKonstantin Kostiuk2022-10-26 19:35:07 +0200
commitc6cd588bb3a29a831c862780631a7d2145ade5de (patch)
treea5003e207e1285709b9d8e0fc85cdf8626327ecd /meson.build
parentMerge tag 'trivial-branch-for-7.2-pull-request' of https://gitlab.com/laurent... (diff)
downloadqemu-c6cd588bb3a29a831c862780631a7d2145ade5de.tar.gz
qemu-c6cd588bb3a29a831c862780631a7d2145ade5de.tar.xz
qemu-c6cd588bb3a29a831c862780631a7d2145ade5de.zip
qga: Add initial FreeBSD support
- Fix device path. - Fix virtio-serial channel initialization. - Make the code buildable in FreeBSD. Reviewed-by: Konstantin Kostiuk <kkostiuk@redhat.com> Acked-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Alexander Ivanov <alexander.ivanov@virtuozzo.com> Signed-off-by: Konstantin Kostiuk <kkostiuk@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b686dfef75..71fe72ea06 100644
--- a/meson.build
+++ b/meson.build
@@ -75,7 +75,7 @@ have_tools = get_option('tools') \
.allowed()
have_ga = get_option('guest_agent') \
.disable_auto_if(not have_system and not have_tools) \
- .require(targetos in ['sunos', 'linux', 'windows'],
+ .require(targetos in ['sunos', 'linux', 'windows', 'freebsd'],
error_message: 'unsupported OS for QEMU guest agent') \
.allowed()
have_block = have_system or have_tools