summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniele Buono2020-12-05 00:06:11 +0100
committerPaolo Bonzini2021-01-02 21:03:09 +0100
commitcdad781d0945a39c936999b75ca18dbf066c1708 (patch)
treef9c31d342175ed4c009d83468b0c0f319ee33b39 /meson.build
parenttarget/i386: Check privilege level for protected mode 'int N' task gate (diff)
downloadqemu-cdad781d0945a39c936999b75ca18dbf066c1708.tar.gz
qemu-cdad781d0945a39c936999b75ca18dbf066c1708.tar.xz
qemu-cdad781d0945a39c936999b75ca18dbf066c1708.zip
configure,meson: add option to enable LTO
This patch allows to compile QEMU with link-time optimization (LTO). Compilation with LTO is handled directly by meson. This patch only adds the option in configure and forwards the request to meson Tested with all major versions of clang from 6 to 12 Signed-off-by: Daniele Buono <dbuono@linux.vnet.ibm.com> Message-Id: <20201204230615.2392-2-dbuono@linux.vnet.ibm.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 372576f82c..d05d880114 100644
--- a/meson.build
+++ b/meson.build
@@ -2080,6 +2080,7 @@ summary_info += {'gprof enabled': config_host.has_key('CONFIG_GPROF')}
summary_info += {'sparse enabled': sparse.found()}
summary_info += {'strip binaries': get_option('strip')}
summary_info += {'profiler': config_host.has_key('CONFIG_PROFILER')}
+summary_info += {'link-time optimization (LTO)': get_option('b_lto')}
summary_info += {'static build': config_host.has_key('CONFIG_STATIC')}
if targetos == 'darwin'
summary_info += {'Cocoa support': config_host.has_key('CONFIG_COCOA')}