summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-04-20 17:33:55 +0200
committerPaolo Bonzini2022-05-07 07:46:58 +0200
commitce6119dc8e025f17c38926aa793f96ed74cb3cc0 (patch)
treeab627c8050a19c484db4cb349ea6c4c4af74ecec /meson.build
parentmeson, configure: move --with-pkgversion, CONFIG_STAMP to meson (diff)
downloadqemu-ce6119dc8e025f17c38926aa793f96ed74cb3cc0.tar.gz
qemu-ce6119dc8e025f17c38926aa793f96ed74cb3cc0.tar.xz
qemu-ce6119dc8e025f17c38926aa793f96ed74cb3cc0.zip
meson, configure: move --interp-prefix to meson
This is the last CONFIG_* entry in config-host.mak that had to be special cased. Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 4ddc72f070..20d9074c4f 100644
--- a/meson.build
+++ b/meson.build
@@ -2228,10 +2228,8 @@ if targetos == 'windows' and link_language == 'cpp'
endif
config_host_data.set('HAVE_VSS_SDK', have_vss_sdk)
-ignored = ['CONFIG_QEMU_INTERP_PREFIX', # actually per-target
- 'HAVE_GDB_BIN']
foreach k, v: config_host
- if k.startswith('CONFIG_') and not ignored.contains(k)
+ if k.startswith('CONFIG_')
config_host_data.set(k, v == 'y' ? 1 : v)
endif
endforeach
@@ -2337,7 +2335,7 @@ foreach target : target_dirs
config_target += {
'CONFIG_USER_ONLY': 'y',
'CONFIG_QEMU_INTERP_PREFIX':
- config_host['CONFIG_QEMU_INTERP_PREFIX'].format(config_target['TARGET_NAME'])
+ get_option('interp_prefix').replace('%M', config_target['TARGET_NAME'])
}
endif