summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBin Meng2022-08-02 09:51:58 +0200
committerMarc-André Lureau2022-09-02 13:54:46 +0200
commitd409373b9d0482bbce312539d02a648cbb1c790a (patch)
treecb47b4d4406aae190c2e9a932f40f52fb414fe3f /meson.build
parentOpen 7.2 development tree (diff)
downloadqemu-d409373b9d0482bbce312539d02a648cbb1c790a.tar.gz
qemu-d409373b9d0482bbce312539d02a648cbb1c790a.tar.xz
qemu-d409373b9d0482bbce312539d02a648cbb1c790a.zip
util/qemu-sockets: Enable unix socket support on Windows
Support for the unix socket has existed both in BSD and Linux for the longest time, but not on Windows. Since Windows 10 build 17063 [1], the native support for the unix socket has come to Windows. Starting this build, two Win32 processes can use the AF_UNIX address family over Winsock API to communicate with each other. [1] https://devblogs.microsoft.com/commandline/af_unix-comes-to-windows/ Signed-off-by: Xuzhou Cheng <xuzhou.cheng@windriver.com> Signed-off-by: Bin Meng <bin.meng@windriver.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20220802075200.907360-3-bmeng.cn@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 20fddbd707..169b18a279 100644
--- a/meson.build
+++ b/meson.build
@@ -1890,6 +1890,9 @@ config_host_data.set('HAVE_PTY_H', cc.has_header('pty.h'))
config_host_data.set('HAVE_SYS_DISK_H', cc.has_header('sys/disk.h'))
config_host_data.set('HAVE_SYS_IOCCOM_H', cc.has_header('sys/ioccom.h'))
config_host_data.set('HAVE_SYS_KCOV_H', cc.has_header('sys/kcov.h'))
+if targetos == 'windows'
+ config_host_data.set('HAVE_AFUNIX_H', cc.has_header('afunix.h'))
+endif
# has_function
config_host_data.set('CONFIG_ACCEPT4', cc.has_function('accept4'))