summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé2022-04-26 18:00:43 +0200
committerDr. David Alan Gilbert2022-05-16 12:46:04 +0200
commitd47b83b118eed26e10ff4693fb1f0a433a38d0a0 (patch)
tree732a242587b2f04c896e6bc46becfe415872d428 /meson.build
parenttests: add migration tests of TLS with PSK credentials (diff)
downloadqemu-d47b83b118eed26e10ff4693fb1f0a433a38d0a0.tar.gz
qemu-d47b83b118eed26e10ff4693fb1f0a433a38d0a0.tar.xz
qemu-d47b83b118eed26e10ff4693fb1f0a433a38d0a0.zip
tests: add migration tests of TLS with x509 credentials
This validates that we correctly handle migration success and failure scenarios when using TLS with x509 certificates. There are quite a few different scenarios that matter in relation to hostname validation. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com> Message-Id: <20220426160048.812266-5-berrange@redhat.com> Reviewed-by: Eric Blake <eblake@redhat.com> Signed-off-by: Dr. David Alan Gilbert <dgilbert@redhat.com> dgilbert: Manual merge due to ifdef change in 3
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9b20dcd143..93aa31a9e4 100644
--- a/meson.build
+++ b/meson.build
@@ -1742,6 +1742,7 @@ config_host_data.set('CONFIG_KEYUTILS', keyutils.found())
config_host_data.set('CONFIG_GETTID', has_gettid)
config_host_data.set('CONFIG_GNUTLS', gnutls.found())
config_host_data.set('CONFIG_GNUTLS_CRYPTO', gnutls_crypto.found())
+config_host_data.set('CONFIG_TASN1', tasn1.found())
config_host_data.set('CONFIG_GCRYPT', gcrypt.found())
config_host_data.set('CONFIG_NETTLE', nettle.found())
config_host_data.set('CONFIG_QEMU_PRIVATE_XTS', xts == 'private')