summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2022-01-18 18:05:48 +0100
committerPaolo Bonzini2022-01-27 12:08:53 +0100
commitde47b0ff40cae050a1ab674d7f4f097c12c527c6 (patch)
tree4075ab2a6a38ff2662069957fd96401fddec2dc8 /meson.build
parentintc: Unexport InterruptStatsProviderClass-related functions (diff)
downloadqemu-de47b0ff40cae050a1ab674d7f4f097c12c527c6.tar.gz
qemu-de47b0ff40cae050a1ab674d7f4f097c12c527c6.tar.xz
qemu-de47b0ff40cae050a1ab674d7f4f097c12c527c6.zip
meson.build: Use a function from libfdt 1.5.1 for the library check
The fdt version test in meson.build uses a function from libfdt v1.4.7, but we require version 1.5.1 nowadays. Thus use a function that has been introduced in that version instead. Resolves: https://gitlab.com/qemu-project/qemu/-/issues/822 Signed-off-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Alistair Francis <alistair.francis@wdc.com> Reviewed-by: David Gibson <david@gibson.dropbear.id.au> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20220118170548.97288-1-thuth@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 833fd6bc4c..4429fd2041 100644
--- a/meson.build
+++ b/meson.build
@@ -2279,7 +2279,7 @@ if have_system
if fdt.found() and cc.links('''
#include <libfdt.h>
#include <libfdt_env.h>
- int main(void) { fdt_check_full(NULL, 0); return 0; }''',
+ int main(void) { fdt_find_max_phandle(NULL, NULL); return 0; }''',
dependencies: fdt)
fdt_opt = 'system'
elif fdt_opt == 'system'