summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2020-11-14 11:10:11 +0100
committerThomas Huth2020-11-17 09:45:24 +0100
commitded5d78c1eada3cd07b22259305a9e2ae332839c (patch)
tree62ce3bb64b27cdd4b9e17984ee1313ec85825a25 /meson.build
parentconfigure: Do not build pc-bios/optionrom on Haiku (diff)
downloadqemu-ded5d78c1eada3cd07b22259305a9e2ae332839c.tar.gz
qemu-ded5d78c1eada3cd07b22259305a9e2ae332839c.tar.xz
qemu-ded5d78c1eada3cd07b22259305a9e2ae332839c.zip
configure: Add a proper check for sys/ioccom.h and use it in tpm_ioctl.h
On Solaris and Haiku, the _IO() macros are defined in <sys/ioccom.h>. Add a proper check for this header to our build system, and make sure to include the header in tpm_ioctl.h to fix a build failure on Solaris and Haiku. Message-Id: <20201115152317.42752-1-thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 132bc49782..30f86ddafb 100644
--- a/meson.build
+++ b/meson.build
@@ -794,6 +794,8 @@ config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0]
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])
config_host_data.set('QEMU_VERSION_MICRO', meson.project_version().split('.')[2])
+config_host_data.set('HAVE_SYS_IOCCOM_H', cc.has_header('sys/ioccom.h'))
+
ignored = ['CONFIG_QEMU_INTERP_PREFIX'] # actually per-target
arrays = ['CONFIG_AUDIO_DRIVERS', 'CONFIG_BDRV_RW_WHITELIST', 'CONFIG_BDRV_RO_WHITELIST']
strings = ['HOST_DSOSUF', 'CONFIG_IASL']