summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:55:56 +0200
committerPaolo Bonzini2020-10-12 17:50:19 +0200
commite28ab096bf897310fc7a37fdc087e66a24e6e977 (patch)
tree8c1c715fe65c7b775e33996ca5f8574af2198833 /meson.build
parentmeson.build: Sort sourcesets alphabetically (diff)
downloadqemu-e28ab096bf897310fc7a37fdc087e66a24e6e977.tar.gz
qemu-e28ab096bf897310fc7a37fdc087e66a24e6e977.tar.xz
qemu-e28ab096bf897310fc7a37fdc087e66a24e6e977.zip
hw/core: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-4-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index adcfb494a8..6c760b4163 100644
--- a/meson.build
+++ b/meson.build
@@ -1469,6 +1469,12 @@ libqmp = static_library('qmp', qmp_ss.sources() + genh,
qmp = declare_dependency(link_whole: [libqmp])
+libhwcore = static_library('hwcore', sources: hwcore_files + genh,
+ name_suffix: 'fa',
+ build_by_default: false)
+hwcore = declare_dependency(link_whole: libhwcore)
+common_ss.add(hwcore)
+
###########
# Targets #
###########