summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorWarner Losh2021-08-04 01:17:17 +0200
committerWarner Losh2021-09-10 22:13:06 +0200
commite2a74729181c51a0c9dff03bb7a99fc267bec996 (patch)
tree27c763a4ccfde547b31c508a45e6baaabce84ac9 /meson.build
parentbsd-user: save the path to the qemu emulator (diff)
downloadqemu-e2a74729181c51a0c9dff03bb7a99fc267bec996.tar.gz
qemu-e2a74729181c51a0c9dff03bb7a99fc267bec996.tar.xz
qemu-e2a74729181c51a0c9dff03bb7a99fc267bec996.zip
bsd-user: start to move target CPU functions to target_arch*
Move the CPU functions into target_arch_cpu.c that are unique to each CPU. These are defined in target_arch.h. Signed-off-by: Stacey Son <sson@FreeBSD.org> Signed-off-by: Warner Losh <imp@bsdimp.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7e58e6279b..9a64d16943 100644
--- a/meson.build
+++ b/meson.build
@@ -2569,9 +2569,12 @@ foreach target : target_dirs
if 'CONFIG_LINUX_USER' in config_target
base_dir = 'linux-user'
target_inc += include_directories('linux-user/host/' / config_host['ARCH'])
- else
+ endif
+ if 'CONFIG_BSD_USER' in config_target
base_dir = 'bsd-user'
- target_inc += include_directories('bsd-user/freebsd')
+ target_inc += include_directories('bsd-user/' / targetos)
+ dir = base_dir / abi
+ arch_srcs += files(dir / 'target_arch_cpu.c')
endif
target_inc += include_directories(
base_dir,