summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-10-07 15:06:10 +0200
committerPaolo Bonzini2021-10-14 09:50:56 +0200
commite5424a2997bd5c6d480e80d3aa106bd4fba5fa7c (patch)
tree7972f1f775a8c322af6f068bb34c7412b9fecddc /meson.build
parentconfigure, meson: move audio driver detection to Meson (diff)
downloadqemu-e5424a2997bd5c6d480e80d3aa106bd4fba5fa7c.tar.gz
qemu-e5424a2997bd5c6d480e80d3aa106bd4fba5fa7c.tar.xz
qemu-e5424a2997bd5c6d480e80d3aa106bd4fba5fa7c.zip
meson: define symbols for all available audio drivers
All drivers are now built by default if the corresponding libraries are available, similar to how all other modules behave; --audio-drv-list only governs the default choice of the audio driver. Adjust the CONFIG_AUDIO_* preprocessor symbols so that they are based on library availability rather than --audio-drv-list, so that the tests and -audiodev help follow the new logic. Cc: Gerd Hoffman <kraxel@redhat.com> Cc: Volker RĂ¼melin <vr_qemu@t-online.de> Message-Id: <20211007130630.632028-5-pbonzini@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 90d1b7ab61..0b9ebf9bfb 100644
--- a/meson.build
+++ b/meson.build
@@ -1217,6 +1217,9 @@ if have_system
'pa': pulse.found(),
'sdl': sdl.found(),
}
+ foreach k, v: audio_drivers_available
+ config_host_data.set('CONFIG_AUDIO_' + k.to_upper(), v)
+ endforeach
# Default to native drivers first, OSS second, SDL third
audio_drivers_priority = \
@@ -1239,9 +1242,6 @@ if have_system
endif
endforeach
endif
-foreach k: audio_drivers_selected
- config_host_data.set('CONFIG_AUDIO_' + k.to_upper(), true)
-endforeach
config_host_data.set('CONFIG_AUDIO_DRIVERS',
'"' + '", "'.join(audio_drivers_selected) + '", ')