summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorIgor Mammedov2021-09-02 13:35:38 +0200
committerMichael S. Tsirkin2021-10-20 10:37:55 +0200
commite741aff0f43343d6d91242fee1072fee376d5cce (patch)
treee928f0166b81453050b4fa95f1dde31677c61366 /meson.build
parenttests: acpi: dump table with failed checksum (diff)
downloadqemu-e741aff0f43343d6d91242fee1072fee376d5cce.tar.gz
qemu-e741aff0f43343d6d91242fee1072fee376d5cce.tar.xz
qemu-e741aff0f43343d6d91242fee1072fee376d5cce.zip
tests: qtest: add qtest_has_accel() to check if tested binary supports accelerator
Currently it is not possible to create tests that have KVM as a hard requirement on a host that doesn't support KVM for tested target binary (modulo going through the trouble of compiling out the offending test case). Following scenario makes test fail when it's run on non x86 host: qemu-system-x86_64 -enable-kvm -M q35,kernel-irqchip=on -smp 1,maxcpus=288 This patch introduces qtest_has_accel() to let users check if accel is available in advance and avoid executing non run-able test-cases. It implements detection of TCG and KVM only, the rest could be added later on, when we actually start testing them in qtest. Signed-off-by: Igor Mammedov <imammedo@redhat.com> Message-Id: <20210902113551.461632-3-imammedo@redhat.com> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9ed9a993e2..2c5b53cbe2 100644
--- a/meson.build
+++ b/meson.build
@@ -75,6 +75,12 @@ else
kvm_targets = []
endif
+kvm_targets_c = ''
+if not get_option('kvm').disabled() and targetos == 'linux'
+ kvm_targets_c = '"' + '" ,"'.join(kvm_targets) + '"'
+endif
+config_host_data.set('CONFIG_KVM_TARGETS', kvm_targets_c)
+
accelerator_targets = { 'CONFIG_KVM': kvm_targets }
if cpu in ['aarch64']