summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-01-14 18:45:08 +0100
committerPaolo Bonzini2021-01-23 21:55:06 +0100
commiteae9a1d18beb2bfe42fc48330a009339dc7e8eee (patch)
tree19892d604bd34828ecced793ca522280bbcf13c2 /meson.build
parentmeson: Add a section header for library dependencies (diff)
downloadqemu-eae9a1d18beb2bfe42fc48330a009339dc7e8eee.tar.gz
qemu-eae9a1d18beb2bfe42fc48330a009339dc7e8eee.tar.xz
qemu-eae9a1d18beb2bfe42fc48330a009339dc7e8eee.zip
meson.build: Declare global edk2_targets / install_edk2_blobs variables
Globally declare in the main meson.build: - the list of EDK2 targets, - whether the EDK2 blobs have to be installed. Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210114174509.2944817-2-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bf52074bd2..94bbb4c757 100644
--- a/meson.build
+++ b/meson.build
@@ -88,6 +88,14 @@ if cpu in ['x86', 'x86_64']
}
endif
+edk2_targets = [ 'arm-softmmu', 'aarch64-softmmu', 'i386-softmmu', 'x86_64-softmmu' ]
+install_edk2_blobs = false
+if get_option('install_blobs')
+ foreach target : target_dirs
+ install_edk2_blobs = install_edk2_blobs or target in edk2_targets
+ endforeach
+endif
+
##################
# Compiler flags #
##################