summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé2020-08-25 12:38:50 +0200
committerEric Blake2020-09-02 23:48:21 +0200
commiteb705985f43d631438a318f1146eac61ae10d273 (patch)
tree0381749b3ba2a4e4b1c1d93d2150c948d525f7fa /meson.build
parentnbd: skip SIGTERM handler if NBD device support is not built (diff)
downloadqemu-eb705985f43d631438a318f1146eac61ae10d273.tar.gz
qemu-eb705985f43d631438a318f1146eac61ae10d273.tar.xz
qemu-eb705985f43d631438a318f1146eac61ae10d273.zip
nbd: disable signals and forking on Windows builds
Disabling these parts are sufficient to get the qemu-nbd program compiling in a Windows build. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com> Message-Id: <20200825103850.119911-4-berrange@redhat.com> Reviewed-by: Eric Blake <eblake@redhat.com> Signed-off-by: Eric Blake <eblake@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 2 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 55c7d2318c..5aaa364730 100644
--- a/meson.build
+++ b/meson.build
@@ -1095,12 +1095,9 @@ if have_tools
dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)
qemu_io = executable('qemu-io', files('qemu-io.c'),
dependencies: [block, qemuutil], install: true)
- qemu_block_tools += [qemu_img, qemu_io]
- if targetos != 'windows'
- qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
+ qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
dependencies: [block, qemuutil], install: true)
- qemu_block_tools += [qemu_nbd]
- endif
+ qemu_block_tools += [qemu_img, qemu_io, qemu_nbd]
subdir('storage-daemon')
subdir('contrib/rdmacm-mux')