summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-15 13:04:49 +0200
committerPaolo Bonzini2020-08-21 12:30:13 +0200
commitec0d5893da20a5f35dcbd901d98be24346bf9cc2 (patch)
treea3054fbb1ede92b8aa4325c1a499c22bf6c4e921 /meson.build
parentmeson: add qemu-edid (diff)
downloadqemu-ec0d5893da20a5f35dcbd901d98be24346bf9cc2.tar.gz
qemu-ec0d5893da20a5f35dcbd901d98be24346bf9cc2.tar.xz
qemu-ec0d5893da20a5f35dcbd901d98be24346bf9cc2.zip
meson: add virtfs-proxy-helper
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f49f5e08d6..3e9e0a9b33 100644
--- a/meson.build
+++ b/meson.build
@@ -102,6 +102,10 @@ if 'CONFIG_GNUTLS' in config_host
endif
pixman = declare_dependency(compile_args: config_host['PIXMAN_CFLAGS'].split(),
link_args: config_host['PIXMAN_LIBS'].split())
+libattr = not_found
+if 'CONFIG_ATTR' in config_host
+ libattr = declare_dependency(link_args: config_host['LIBATTR_LIBS'].split())
+endif
seccomp = not_found
if 'CONFIG_SECCOMP' in config_host
seccomp = declare_dependency(compile_args: config_host['SECCOMP_CFLAGS'].split(),
@@ -301,6 +305,8 @@ libqemuutil = static_library('qemuutil',
qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)
+subdir('fsdev')
+
# Other build targets
if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')