summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2021-10-28 20:59:08 +0200
committerPaolo Bonzini2021-11-02 15:57:28 +0100
commiteea9453a016b622f74898809f53e0ca85961cd80 (patch)
treeaa4bb73dbdc8ca6d8b4bebe6c4b1eff942fbcc0b /meson.build
parentmeson: remove unnecessary coreaudio test program (diff)
downloadqemu-eea9453a016b622f74898809f53e0ca85961cd80.tar.gz
qemu-eea9453a016b622f74898809f53e0ca85961cd80.tar.xz
qemu-eea9453a016b622f74898809f53e0ca85961cd80.zip
Move the l2tpv3 test from configure to meson.build
And while we're at it, also provide a proper entry for this feature in meson_options.txt, so that people who don't need it have a knob to disable this feature. Signed-off-by: Thomas Huth <thuth@redhat.com> Message-Id: <20211028185910.1729744-3-thuth@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 30b06b12b4..e330438270 100644
--- a/meson.build
+++ b/meson.build
@@ -1658,6 +1658,13 @@ config_host_data.set('HAVE_MLOCKALL', cc.links(gnu_source_prefix + '''
return mlockall(MCL_FUTURE);
}'''))
+have_l2tpv3 = false
+if not get_option('l2tpv3').disabled() and have_system
+ have_l2tpv3 = (cc.has_header_symbol('sys/socket.h', 'struct mmsghdr')
+ and cc.has_header('linux/ip.h'))
+endif
+config_host_data.set('CONFIG_L2TPV3', have_l2tpv3)
+
have_netmap = false
if not get_option('netmap').disabled() and have_system
have_netmap = cc.compiles('''
@@ -3377,6 +3384,7 @@ summary_info += {'JACK support': jack}
summary_info += {'brlapi support': brlapi}
summary_info += {'vde support': vde}
summary_info += {'netmap support': have_netmap}
+summary_info += {'l2tpv3 support': have_l2tpv3}
summary_info += {'Linux AIO support': libaio}
summary_info += {'Linux io_uring support': linux_io_uring}
summary_info += {'ATTR/XATTR support': libattr}