summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2019-07-18 13:19:02 +0200
committerPaolo Bonzini2020-08-21 12:30:12 +0200
commitf15bff25f7c6843d698e122dc8d1b5927360f6c1 (patch)
treed3f50045525d19e6290bcdac8519b9c10b779fc6 /meson.build
parentmeson: add solaris and Haiku libraries (diff)
downloadqemu-f15bff25f7c6843d698e122dc8d1b5927360f6c1.tar.gz
qemu-f15bff25f7c6843d698e122dc8d1b5927360f6c1.tar.xz
qemu-f15bff25f7c6843d698e122dc8d1b5927360f6c1.zip
meson: convert qemu-ga
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8d764a9431..5cd8ee0298 100644
--- a/meson.build
+++ b/meson.build
@@ -132,6 +132,10 @@ if 'CONFIG_CURL' in config_host
curl = declare_dependency(compile_args: config_host['CURL_CFLAGS'].split(),
link_args: config_host['CURL_LIBS'].split())
endif
+libudev = not_found
+if 'CONFIG_LIBUDEV' in config_host
+ libudev = declare_dependency(link_args: config_host['LIBUDEV_LIBS'].split())
+endif
target_dirs = config_host['TARGET_DIRS'].split()
have_user = false
@@ -294,6 +298,10 @@ qemuutil = declare_dependency(link_with: libqemuutil,
# Other build targets
+if 'CONFIG_GUEST_AGENT' in config_host
+ subdir('qga')
+endif
+
if have_tools
subdir('contrib/rdmacm-mux')
subdir('contrib/elf2dmp')