summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorRichard Henderson2020-09-12 19:47:33 +0200
committerRichard Henderson2020-10-03 11:25:14 +0200
commitf343346b147b8871d628defa4fe038eb1a2e4e08 (patch)
tree9659a5f01a79cccacf9c7e0dcaf48dbfcb252ecc /meson.build
parentdisas: Configure capstone for aarch64 host without libvixl (diff)
downloadqemu-f343346b147b8871d628defa4fe038eb1a2e4e08.tar.gz
qemu-f343346b147b8871d628defa4fe038eb1a2e4e08.tar.xz
qemu-f343346b147b8871d628defa4fe038eb1a2e4e08.zip
disas: Split out capstone code to disas/capstone.c
There is nothing target-specific about this code, so it can be added to common_ss. This also requires that the base capstone dependency be added to common_ss, so that we get the correct include paths added to CFLAGS. Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ccad7cabf1..bb13fcf98c 100644
--- a/meson.build
+++ b/meson.build
@@ -1104,6 +1104,7 @@ common_ss.add(files('cpus-common.c'))
subdir('softmmu')
+common_ss.add(capstone)
specific_ss.add(files('disas.c', 'exec.c', 'gdbstub.c'), capstone, libpmem, libdaxctl)
specific_ss.add(files('exec-vary.c'))
specific_ss.add(when: 'CONFIG_TCG', if_true: files(